Troubleshooting

jQuery: Problem with hidden selectbox

I use the jQuery SelectBox Plugin for a select box in a hidden DIV container. The problem was that after removing the hidden CSS class from the container, the jQuery SelectBox was empty. I thought that maybe it is in correlation with this statement from A Beautiful Site:

Since the original controls aren’t destroyed (they’re hidden), you can easily integrate this plugin into just about any existing form.

so the only way to get the SelectBox filled correctly was to first destroy  and then reinitialize it (see the code snippet below).

<style>

.hidden {
  display: none;
}

</style>

<script>
$(document).ready(function() {

  $('#show').bind("click", function(){

     $('#container').removeClass('hidden');
     $("#container select").selectBox('destroy');
     $("#container select").selectBox();

  });

  $("select").selectBox();

});
</script>

<a id="show" href="#">show</a>

<div id="container" class="hidden">
  <select>...</select>
</div>

Windows Azure: Compute Emulator: Can’t locate service model

Just to share, if you get this error messag:

The compute emulator had a error: Can’t locate service model..

for instance when starting “package create …“, the problem could be a too deep project folder structure. In my case caused by the file cache directory of my application. After clearing this directory everything was ok.


Copyright © 2007-2012 iTopia. All rights reserved.
Jarrah theme by Templates Next | Powered by WordPress